Google Translation

Google Translation

You can now personalize chat conversations with visitors using real time chat translation in Zoho SalesIQ using the Google translation integration. This integration translates 100+ languages and enables operators to connect with visitors from all regions in real-time. 

Benefits of Translation:

  1. With real time live chat translation, your operators can assist visitors from different parts of the world, talk to them in their language and make them feel at home. This increases the trust they have on your brand and thus encourages them to visit your website again.
  2. Your operators can type out replies to queries in their language and get them seamlessly translated to the visitor's language when they are sent out. This can save the time they spend on decoding visitor queries.
  3. This feature can be extremely beneficial for businesses like travel agencies, educational institutions, online health care services, online shopping, etc.

How to enable Google translation integration?

  • In Settings > Integrations > Translate, select Google translate. Click Add.

  • Now under Let's configure section, enter the API generated for you Google translate account and click Enable.

  • Once enabled you can use Google translation services to translate messages in real time. 

Configuring Google Translation:

After integrating Google translation with SalesIQ, you can either choose to initiate translation automatically when a foreign language is detected or manually translate when required. 
  • To change the preference, in Settings > Integration > Translate > Google translation > Advanced configuration.
  • Choose your preferred option,  
    • Translate automatically - Messages will be instantly translated to the operators language when a foreign language is detected. 
    • Translate manually - Operators can choose to translate the message if they want, until then the chat will be shown in their original language. 

How to translate chats?

You can now support visitors from different countries in their own languages. Zoho SalesIQ instantly uses Google translator to translate visitors' messages on reception. Once the chat is received a message will be displayed. You can click on “Translate” to get the chat translated or click on the “x” to continue chatting in the visitor's language. 


The chat will be translated automatically once the "  Translate" is clicked.

Stop Translation During Chat

You can stop the translation at any time during the chat if you want to continue the chat in the visitor's language. 
To stop translation,
  1. You can click on the Stop button on the top of the screen.
  2. You can continue translation on need even if it is been stopped before by clicking on the Translate button.

To View the Original Transcript

If you wish to view the Original Transcript, then click on the double arrow that appears on the top of the screen.

Note :To get the Google translation activated make sure you enable it in  Portal Settings.

Common Errors that occurs while using google translation service

Issue

Cause

Same text appearing twice

Certain sentences of a language might have multiple words that convey the same meaning but when translated to another language the same word might be repeated twice.

Increase of letters after translations

Sentences might get longer when converting to a certain language.

Dynamic text failure

While translating to certain languages like Russian, Japanese, Spanish will fail to translate dynamic texts.

Emojis not supported

Some languages like Chinese and Japanese might not support be translated properly.

Failure in small talk translation

Could have reached translation limit in your account.

Failure in formatted text translation

Translator based issue.

In FAQ for some of the languages, translation is failing continuously.

Translator based issue.

 

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